Tag: configuration

Controlling Configuration Load Order in Sitecore 9

New with Sitecore 9 is the ability to specify the ability in which config files load.  Loading in Alphabetical order is soooo 2016.  There’s some work arounds for it, but nothing official.  All that has changed with Sitecore 9! If you navigate to the App_Config folder, you’ll see a Layers.config file.  It looks something like…


Using Set in Configuration Files for Sitecore 9

This is a quick one, but man is it sexy.  I’m loving the new configuration support in Sitecore 9.  Let’s take a look at the new “set” command in the patch configuration. Here’s how we could update two site values in the previous versions of Sitecore:

Is that impossible to figure out? Nah.  Can…


Server Role Configuration in Sitecore 9

New with Sitecore 9 is the ability to specify server roles.  There is nothing new here when it comes to the roles available, however. It’s still your typical Authoring, Delivery, Processing and Reporting roles.  There is another new “role” called “Standalone” which is “all roles” such as something you’d see for a Dev Environment. Sitecore…


Switching Search Providers in Sitecore 9

We all remember the pain involved in switching Search Providers from Lucene to Solr.  There were many a tales of woe.  It crushed dreams.  Drinks were had in order to lament. Maybe it wasn’t that bad.  But… Sitecore listened to us! With Sitecore 9, switching search providers is EASY.  How easy? Check out the setting…


JSON Serialization Issues with Delivery Servers (k__BackingField)

We recently ran into an issue where the same code deployed to our authoring server wasn’t behaving as it should on our delivery servers.  On each sever, we were making use of WebAPI to grab some data from the server and bind it to knockout.  Seems easy enough, no?  There’s a small catch though: Serialization….


Sitecore Hangs on Item Save or Create

I’m posting this up here mostly for me, in case I run into this again.  Our new Sitecore install was having some serious issues.  You could browse the tree and do everything as expected in Content Editor.  When you went to save an item, poof.  The whole browser froze.  You couldn’t click around, and it…